ProNavigator Document Access
Incident Report for ProNavigator
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 11:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
A browser refresh may be required.
Posted Apr 25, 2022 - 10:01 EDT
Investigating
We are currently investigating an issue that prevents certain documents from being accessed.
Posted Apr 25, 2022 - 09:32 EDT
This incident affected: Sage (Ask Sage).