Access to Service
Incident Report for ProNavigator
Resolved
All systems are operational and we will continue to monitor.

We apologize for the interruption and greatly appreciate your patience throughout this process.
Posted Jul 11, 2023 - 14:01 EDT
Update
We have made progress on restoring system availability however we are aware problems remain for some users.

We are continuing to implement solutions to restore full system functionality and we will provide continued updates on our progress.
Posted Jul 11, 2023 - 13:51 EDT
Update
Some users are still experiencing delays or inconsistency in our service around Search and Filters functionality.

We have identified the root cause and are currently working on a resolution that will ensure all aspects of the platform are fully functional.

Updates will continue to be provided as availability of services is completely restored.
Posted Jul 11, 2023 - 12:45 EDT
Update
Some users are still experiencing delays in our service. We are continuing to trouble shoot to get the service back to normal.
Posted Jul 11, 2023 - 11:33 EDT
Monitoring
Service is returning to normal, some users are still experiencing intermittent delays. We are continuing to monitor.
Posted Jul 11, 2023 - 09:50 EDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2023 - 09:10 EDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2023 - 09:10 EDT
Investigating
We are investigating an issue where users attempting to access their ProNavigator account's are not able to. We are actively investigating
Posted Jul 11, 2023 - 09:09 EDT
This incident affected: ProNavigator (ProNavigator Platform, Library, Login).