Degraded performance of Dashboard and Library

Incident Report for ProNavigator

Resolved

The team has scaled up servers and usage has returned to normal.
Posted Mar 18, 2024 - 12:03 EDT

Identified

Some users are experiencing slowness loading content on the dashboard and library pages.
Posted Mar 18, 2024 - 11:54 EDT
This incident affected: ProNavigator (ProNavigator Platform, Library).