Compass Responses
Incident Report for ProNavigator
Resolved
This incident has been resolved.
Posted May 24, 2022 - 12:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2022 - 12:20 EDT
Identified
An issue has been identified affecting our compass product.

The issue has been investigated and a fix is being implemented.
Posted May 24, 2022 - 09:34 EDT