Announcements Module Outage
Incident Report for ProNavigator
Resolved
Our team has deployed a fix and the Announcement Module is now fully operational.
Posted Mar 12, 2024 - 12:39 EDT
Identified
We are currently experiencing technical issues with the Announcements module. The problem has been identified, and our team is actively working on a fix. We expect to resolve the issue within the next hour. We appreciate your patience and understanding.
Posted Mar 12, 2024 - 12:14 EDT
This incident affected: ProNavigator (ProNavigator Platform).